文档 下载安装 商店 博客 问答 主机

Magento网站搜索显示该网页无法正常运作无法处理此请求

后端
错误

#1

请教:
本人有一个网站 http://www.mellowermarket.com
之前在搜索框键入产品名称一直可以实现模糊搜索。
但不知道从何时起,最近在网站上输入产品名称,比如“apple”,
结果如下图所示:
该网页无法正常运作
www.mellowermarket.com 目前无法处理此请求。
HTTP ERROR 500


申明本人是代码小白,从未对网站文件做过代码修改,
所以我想应该可以排除代码方面的问题,主机服务商也说不是他们服务器的问题,所以我猜,是否是我对magento后台的哪一步设置,才导致这个问题?
本人的magento版本是:Magento ver. 1.9.0.1
万分着急!望哪位牛人指点迷津。
非常感谢!!


#2

首先请尽快升级你的Magento,版本太低了.该版本有重大漏洞,不排除是被入侵后修改之后造成的错误.

About PHP500错误

Magento发生Php500错误,大部分原因都会是因为权限问题。但是由于没有开放错误提示,所以没有办法查看具体造成错误的原因。
你可以先尝试才用这个方法查看具体的错误信息:

在Magento中,你可以尝试修改根目录下的Index.php文件.
有一个关于display error的设置。
修改之后,请再把详细的错误日志发上来,这样才能帮户到你.


#4

谢谢Shuai.

我打开了根目录下的index.php,里面倒是有一个display_errors的字段,如图:

我应该怎么修改呢?改成display_errors = On就可以了吗?
还是要再需要添加其他语句?紧接着加 error_reporting = E_ALL | E_STRICT???

之前我还在magento的后台Developer下开启了log settings,
然后在Var目录下手动添加了一个log文件夹(本来以为它会自动创建的),
然后在网站前台搜索了几次,但是后台一直没有报错的日志文件出现。
这是不是因为display_error还没有开启的缘故?所以它不显示报错的日志?


#5

在你index.php 头部加入两行

error_reporting(E_ALL);
ini_set(“display_errors”, 1);

应该能看到报错信息


#6

谢谢回复!
见笑,本人是代码小白一枚,是这样添加吗?


添加以后,保存,上传。在前台搜索,还是一样哎。
再查看log文件夹,还是没有报错的日志文件。


#7

加在

<?php 后面,另换一行

#8

哦哦~~
直接加在<?php之后,然后换行是吗?那就是。。。


对吧?非常感谢你的耐心。见笑见笑!


#9

啊,不对,应该是这样是吧?


#10

嗯,试试吧~。。。


#12

保存上传以后,我在前台搜索了几次。
结果,嗨,log文件下还真出现一个error reporting日志报告了,具体如下:
牛人可以指点一二,看看这是因为什么错误吗?


#13

(接上图)这是图2.。。。。。。。。。。


#14

去掉注释就行,Magento内置了.


#15

谢谢Shuai!
小白的特点就是:两眼一抹黑,啥也不懂。
具体怎么去掉呢?
是整个一行都去掉?
或是去掉(‘display_errors’, 1)只留下 #ini_set
然后其他(包括上面的修改)保持不动吗?
惭愧!谢谢谢谢!


#16

要么我发个红包,哪位懂行的仁兄帮忙解决一下。
这个问题弄一下应该付多少银子?:grin::grinning::slight_smile:


#17

你这个要先把错误调试出来,看看是什么原因才行。
去掉前面的井号就行了。


#18

我去掉了前面的#号,其他保持原样。
然后在前台尝试搜索,结果页面显示一片空白哎:sweat:
这样不提示任何错误照样让人很蛋疼


#19

一片空白还有一个可能的原因会是内存不够,检查php.ini或者.htaccess。给php更多的内存。


#20

非常抱歉,忘了谢谢!惭愧,自己还真不知道怎么加内存。
前段时间确实因为内存过高问题主机商对网站做过一次audit,审计。
不知道是不是因为这个原因。
我联系主机商问问看。


#21

Magento个人建议还是至少使用VPS来运行,特别是正式站。所以VPS的情况下,自己肯定是有权限修改php和magento使用的内存的。


#22

好,感谢!
所以。。要想不出问题,还是得多掏银子才行是吧?:slight_smile:
敢问兄台,VPS一年正常的价位一般得多少?