# Access denied for user 'user'@'localhost' (using password: NO) 怎样解决?

**URL:** https://forum.magentochina.org/t/access-denied-for-user-userlocalhost-using-password-no-%E6%80%8E%E6%A0%B7%E8%A7%A3%E5%86%B3/162
**Category:** 提问
**Tags:** magento2, mysql
**Created:** [2017 年11 月 18 日 16:20 UTC](https://forum.magentochina.org/t/access-denied-for-user-userlocalhost-using-password-no-%E6%80%8E%E6%A0%B7%E8%A7%A3%E5%86%B3/162 "2017-11-18T16:20:26Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### 作者： ![aronine](https://forum.magentochina.org/letter_avatar_proxy/v4/letter/a/71c47a/32.png) [@aronine](https://forum.magentochina.org/u/aronine)
#### 发布日期： [2017 年11 月 18 日 16:20 UTC](https://forum.magentochina.org/t/access-denied-for-user-userlocalhost-using-password-no-%E6%80%8E%E6%A0%B7%E8%A7%A3%E5%86%B3/162/1 "2017-11-18T16:20:26Z")

</div>

本人完全是个新手, 每一次架设 Magento2, 租了云, 放星加坡, 服务器租用: [www.linode.com](http://www.linode.com)  
环境:我按照 Linode 提供的教程已经把 Ubuntu + Nginx + MySQL + PHP 都安装好. ubuntu16.04 + Nginx 1.13.6 + MySQL 5.7 + PHP 7.1.11  
Magento 版本: CE 2.2.1  
新的库名 magento 已经建好在MySQL了  
当我跑cd /var/www/html/bin  
再跑以下  
./magento setup:install --admin-firstname=“John” --admin-lastname=“Charles” [--admin-email="your@email.com](mailto:--admin-email=%22your@email.com)" --admin-user=“john” --admin-password=“password1” --db-name=“magento” --db-host=“localhost” --db-user=“magento” --db-password="password"  
就出现了以下错误回传

```auto
SQLSTATE[HY000] [1045] Access denied for user 'user'@'localhost' (using password: NO)
[InvalidArgumentException]
  Parameter validation failed

```

我在 MySQL 查过, root@localhost 已经存在

```auto
mysql> select user, host from user;
+------------------+-----------+
| user | host |
+------------------+-----------+
| magento | % |
| user | % |
| debian-sys-maint | localhost |
| mysql.session | localhost |
| mysql.sys | localhost |
| root | localhost |
+------------------+-----------+
6 rows in set (0.00 sec)

```

有没有大神曾经遇过这个情况, 请赐教.

---

<div class="post-metadata">

### 作者： ![Shuai](https://forum.magentochina.org/user_avatar/forum.magentochina.org/shuai/32/3_2.png) [@Shuai](https://forum.magentochina.org/u/Shuai)
#### 发布日期： [2017 年11 月 18 日 16:43 UTC](https://forum.magentochina.org/t/access-denied-for-user-userlocalhost-using-password-no-%E6%80%8E%E6%A0%B7%E8%A7%A3%E5%86%B3/162/2 "2017-11-18T16:43:29Z")

</div>

> [@aronine](#):
>
> –db-user=“magento” --db-password=“password”

mysql的账号或者密码错误，这里你设置的mysql用户名是magento，密码password。  
另外，linode的新加坡机房并不快，国内访问需要绕道美国。不如直接买美国的节点了

---

<div class="post-metadata">

### 作者： ![aronine](https://forum.magentochina.org/letter_avatar_proxy/v4/letter/a/71c47a/32.png) [@aronine](https://forum.magentochina.org/u/aronine)
#### 发布日期： [2017 年11 月 18 日 18:05 UTC](https://forum.magentochina.org/t/access-denied-for-user-userlocalhost-using-password-no-%E6%80%8E%E6%A0%B7%E8%A7%A3%E5%86%B3/162/3 "2017-11-18T18:05:26Z")

</div>

我用上了  
–db-user=“root” --db-password="\*\*\*"  
过了, 这样设置, 不是最佳设定方法对吗?

---

<div class="post-metadata">

### 作者： ![Shuai](https://forum.magentochina.org/user_avatar/forum.magentochina.org/shuai/32/3_2.png) [@Shuai](https://forum.magentochina.org/u/Shuai)
#### 发布日期： [2017 年11 月 18 日 18:27 UTC](https://forum.magentochina.org/t/access-denied-for-user-userlocalhost-using-password-no-%E6%80%8E%E6%A0%B7%E8%A7%A3%E5%86%B3/162/4 "2017-11-18T18:27:54Z")

</div>

> [@aronine](#):
>
> 过了, 这样设置, 不是最佳设定方法对吗?

是的，但是请确认一下账号用户名是否正确，请先使用

> mysql -umagento -ppassword

> [@aronine](#):
>
> –db-user=“magento” --db-password=“password”

这两个要相匹配。

---

<div class="post-metadata">

### 作者： ![aronine](https://forum.magentochina.org/letter_avatar_proxy/v4/letter/a/71c47a/32.png) [@aronine](https://forum.magentochina.org/u/aronine)
#### 发布日期： [2017 年11 月 18 日 18:37 UTC](https://forum.magentochina.org/t/access-denied-for-user-userlocalhost-using-password-no-%E6%80%8E%E6%A0%B7%E8%A7%A3%E5%86%B3/162/5 "2017-11-18T18:37:06Z")

</div>

[SUCCESS]: Magento installation complete.  
[SUCCESS]: Magento Admin URI: /admin\_\*\*\*\*\*\*  
Nothing to import.

我用 root 完成了 MYSQL 的表的倒入了  
算是安装完成了  
但打了 [http://www.domain.com/admin](http://www.domain.com/admin) 没有进入管理登入页面  
请教在那里能找到管理员页面路径  
另外有好的教学推荐, 讲解如何安装 Mangeto2 到 Ubuntu + Nginx + PHP + MYSQL 吗?  
跪谢了

---

<div class="post-metadata">

### 作者： ![Shuai](https://forum.magentochina.org/user_avatar/forum.magentochina.org/shuai/32/3_2.png) [@Shuai](https://forum.magentochina.org/u/Shuai)
#### 发布日期： [2017 年11 月 18 日 18:44 UTC](https://forum.magentochina.org/t/access-denied-for-user-userlocalhost-using-password-no-%E6%80%8E%E6%A0%B7%E8%A7%A3%E5%86%B3/162/6 "2017-11-18T18:44:54Z")

</div>

> [@aronine](#):
>
> 我用 root 完成了 MYSQL 的表的倒入了

这证明是用户密码不对，或者没有赋予magento这个mysql user权限，所以没有成功.

命令执行完成时，会有提示正确的后台URL，如果找不到了，可以使用命令行查询Magento的后台url地址:

> bin/magento info:adminuri

---

<div class="post-metadata">

### 作者： ![aronine](https://forum.magentochina.org/letter_avatar_proxy/v4/letter/a/71c47a/32.png) [@aronine](https://forum.magentochina.org/u/aronine)
#### 发布日期： [2017 年11 月 18 日 18:59 UTC](https://forum.magentochina.org/t/access-denied-for-user-userlocalhost-using-password-no-%E6%80%8E%E6%A0%B7%E8%A7%A3%E5%86%B3/162/7 "2017-11-18T18:59:34Z")

</div>

当我建好了新的 MYSQL USER, 我去 /var/www/html/app/etc 修改 env.php 里参数对吗?

我找到了 admin URI , 打了 [www.domain.com/admin\_URI](http://www.domain.com/admin_URI), 但是管理页面还是没有跳出来, 是因为我的 NGINX 设置错误?

---

<div class="post-metadata">

### 作者： ![Shuai](https://forum.magentochina.org/user_avatar/forum.magentochina.org/shuai/32/3_2.png) [@Shuai](https://forum.magentochina.org/u/Shuai)
#### 发布日期： [2017 年11 月 18 日 19:34 UTC](https://forum.magentochina.org/t/access-denied-for-user-userlocalhost-using-password-no-%E6%80%8E%E6%A0%B7%E8%A7%A3%E5%86%B3/162/8 "2017-11-18T19:34:52Z")

</div>

> [@aronine](#):
>
> 是因为我的 NGINX 设置错误?

应该是nginx配置的问题。请参考官方的nginx.conf  
[https://github.com/magento/magento2/blob/2.2-develop/nginx.conf.sample](https://github.com/magento/magento2/blob/2.2-develop/nginx.conf.sample)  
判断是否是URL rewrite的问题，[可以尝试在domain.com/index.php/admin\_URL试试，如果访问的不是404，那证明有问题。](http://xn--domain-2x8i375agjhtlnl31k.com/index.php/admin_URL%E8%AF%95%E8%AF%95%EF%BC%8C%E5%A6%82%E6%9E%9C%E8%AE%BF%E9%97%AE%E7%9A%84%E4%B8%8D%E6%98%AF404%EF%BC%8C%E9%82%A3%E8%AF%81%E6%98%8E%E6%9C%89%E9%97%AE%E9%A2%98%E3%80%82)
