# Magento2切换产品模式报错Command returned non-zero exit code

**URL:** https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129
**Category:** Magento 2.X
**Tags:** 报错, 命令行
**Created:** [2017 年11 月 10 日 17:14 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129 "2017-11-10T17:14:33Z")
**Posts on this page:** 15
**Page:** 1

<div class="post-metadata">

### 作者： ![Shuai](https://forum.magentochina.org/user_avatar/forum.magentochina.org/shuai/32/3_2.png) [@Shuai](https://forum.magentochina.org/u/Shuai)
#### 发布日期： [2017 年11 月 10 日 17:14 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/1 "2017-11-10T17:14:33Z")

</div>

Magento2[切换产品模式](https://doc.magentochina.org/guides/v2.1/config-guide/cli/config-cli-subcommands-mode.html#change-to-production-mode)时报错，报错内容类似:

```
bin/magento deploy:mode:set production
Enabled maintenance mode
Starting compilation
Something went wrong while compiling generated code. See the error log for details.
Command returned non-zero exit code:
`/usr/local/php/bin/php -f /wwwroot/magentochina.org/bin/magento setup:di:compile`

```

依次运行下面命令就可以解决该问题:

1. bin/magento setup:upgrade

2. bin/magento indexer:reindex

3. bin/magento deploy:mode:set production -s (or --skip-compilation)

4. bin/magento setup:di:compile (切换至产品模式之后再单独编译,一般在这步就会出现详细的错误信息。如果不能自行解决，可以回复该命令的回显，帮你们查看是什么问题)

5. bin/magento setup:static-content:deploy zh\_Hans\_CN (这里使用了中文包)

---

<div class="post-metadata">

### 作者： ![charles.zhou](https://forum.magentochina.org/letter_avatar_proxy/v4/letter/c/3da27b/32.png) [@charles.zhou](https://forum.magentochina.org/u/charles.zhou)
#### 发布日期： [2018 年3 月 9 日 03:54 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/2 "2018-03-09T03:54:51Z")

</div>

以下是我按照你的命令输入后，在第四步产生的错误回显，非常感谢你的帮忙  
Allowed memory size of 268435456 bytes exhausted (tried to allocate 32 bytes) in /home2/wenorkhv/public\_html/vendor/zendframework/zend-code/src/Scanner/FileScanner.php on line 36

Check [https://getcomposer.org/doc/articles/troubleshooting.md#memory-limit-errors](https://getcomposer.org/doc/articles/troubleshooting.md#memory-limit-errors) for more info on how to handle out of memory errors.

---

<div class="post-metadata">

### 作者： ![Shuai](https://forum.magentochina.org/user_avatar/forum.magentochina.org/shuai/32/3_2.png) [@Shuai](https://forum.magentochina.org/u/Shuai)
#### 发布日期： [2018 年3 月 9 日 16:40 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/3 "2018-03-09T16:40:37Z")

</div>

内存溢出了，加大一点内存试试。

---

<div class="post-metadata">

### 作者： ![charles.zhou](https://forum.magentochina.org/letter_avatar_proxy/v4/letter/c/3da27b/32.png) [@charles.zhou](https://forum.magentochina.org/u/charles.zhou)
#### 发布日期： [2018 年3 月 11 日 17:00 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/4 "2018-03-11T17:00:49Z")

</div>

你好，我换了一个主机，终于可以运行这些代码了。但是我打开I网页的时候依旧报错。  
There has been an error processing your request  
Unable to retrieve deployment version of static files from the file system.  
是因为我这个主机不支持伪静态？ 还是其他原因？

---

<div class="post-metadata">

### 作者： ![Shuai](https://forum.magentochina.org/user_avatar/forum.magentochina.org/shuai/32/3_2.png) [@Shuai](https://forum.magentochina.org/u/Shuai)
#### 发布日期： [2018 年3 月 11 日 17:08 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/5 "2018-03-11T17:08:27Z")

</div>

> [@charles.zhou](#):
>
> There has been an error processing your request
> 
> Unable to retrieve deployment version of static files from the file system

首先尝试给Magento所有文件777权限，再赋予webserver用户组权限。  
然后cd到magento的目录运行以下命令:

> bin/magento se:st:de -f

如果没有报错，再赋予权限一次。  
然后再刷新页面，看看有报错没有.  
任何报错，请发上来再看。

PS.最好说清楚你的服务器环境。

---

<div class="post-metadata">

### 作者： ![charles.zhou](https://forum.magentochina.org/letter_avatar_proxy/v4/letter/c/3da27b/32.png) [@charles.zhou](https://forum.magentochina.org/u/charles.zhou)
#### 发布日期： [2018 年3 月 12 日 02:32 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/6 "2018-03-12T02:32:02Z")

</div>

系统环境：Linux instance-1 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+deb9u3 (2018-03-02) x86\_64  
php7.0  
apache2.4  
mysql 5.7

报错内容： ![image](https://forum.magentochina.org/uploads/default/original/1X/2b1447e2d97efe76310d444571349e8391bbbf10.png)

非常感谢你的回答哈，我不太懂技术，所以只能麻烦你这边了。  
然后服务器环境不知道说系统环境够不够

---

<div class="post-metadata">

### 作者： ![cainiao](https://forum.magentochina.org/user_avatar/forum.magentochina.org/cainiao/32/179_2.png) [@cainiao](https://forum.magentochina.org/u/cainiao)
#### 发布日期： [2018 年3 月 12 日 02:47 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/7 "2018-03-12T02:47:00Z")

</div>

不加-f再试试，你具体是什么版本的M2?

---

<div class="post-metadata">

### 作者： ![charles.zhou](https://forum.magentochina.org/letter_avatar_proxy/v4/letter/c/3da27b/32.png) [@charles.zhou](https://forum.magentochina.org/u/charles.zhou)
#### 发布日期： [2018 年3 月 12 日 02:57 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/8 "2018-03-12T02:57:57Z")

</div>

我不加 -f执行了，然后好像报错了，但是没有反馈具体原因。具体如图：  
 ![image](https://forum.magentochina.org/uploads/default/original/1X/c32668a6674b01ddec93f525fc2906bac9bd54d6.png)

但是网页打不开，全空白

版本的话，不清楚诶，直接用的是主题模板，导入DEMO数据库，然后直接使用的。

正常安装2.2.3的话，在安装过程中好像卡着不动了，一个晚上下来也没安装成功。所以直接用快速安装。能成功。但是速度比较慢，所以尝试着切换生产模式看下~~

---

<div class="post-metadata">

### 作者： ![cainiao](https://forum.magentochina.org/user_avatar/forum.magentochina.org/cainiao/32/179_2.png) [@cainiao](https://forum.magentochina.org/u/cainiao)
#### 发布日期： [2018 年3 月 12 日 03:12 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/9 "2018-03-12T03:12:48Z")

</div>

再付权再试试，不行就查一下php.ini设置的内存限制是多少。空白页可能是内存不够产生的错误。

---

<div class="post-metadata">

### 作者： ![charles.zhou](https://forum.magentochina.org/letter_avatar_proxy/v4/letter/c/3da27b/32.png) [@charles.zhou](https://forum.magentochina.org/u/charles.zhou)
#### 发布日期： [2018 年3 月 12 日 03:23 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/10 "2018-03-12T03:23:01Z")

</div>

![image](https://forum.magentochina.org/uploads/default/original/1X/4c857bb09356c798496e1500cc2cb8367fceb246.png)

我的后台能正常打开~~~好尴尬

然后我改了php中的php.ini中的memory\_limit=2048M  
但好像充phpinfo中看不出效果~~~

---

<div class="post-metadata">

### 作者： ![Shuai](https://forum.magentochina.org/user_avatar/forum.magentochina.org/shuai/32/3_2.png) [@Shuai](https://forum.magentochina.org/u/Shuai)
#### 发布日期： [2018 年3 月 12 日 04:08 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/11 "2018-03-12T04:08:50Z")

</div>

php.ini的任何配置都 **需要重启service** 。  
根据你不能用 **-f** 参数的特征，我估计你的M2是低版本的，你现在能进入后台的话，就进去查看一下版本。  
然后再查看magento根目录下的var/log文件夹下的日志文件，看看能否找到具体的报错信息。

---

<div class="post-metadata">

### 作者： ![charles.zhou](https://forum.magentochina.org/letter_avatar_proxy/v4/letter/c/3da27b/32.png) [@charles.zhou](https://forum.magentochina.org/u/charles.zhou)
#### 发布日期： [2018 年3 月 12 日 04:28 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/12 "2018-03-12T04:28:57Z")

</div>

![image](https://forum.magentochina.org/uploads/default/original/1X/17c0b83bfb8ba915c1bbe01e813c19941907568e.png)  
这个是debug错误记录

Magento的版本为2.1.7版本  
刚刚已经重启服务器了，也是前台网页打不开~~  
Master Value的memory\_limit已经显示2048了，另一个Local Value值不知道在哪改~~~

---

<div class="post-metadata">

### 作者： ![Shuai](https://forum.magentochina.org/user_avatar/forum.magentochina.org/shuai/32/3_2.png) [@Shuai](https://forum.magentochina.org/u/Shuai)
#### 发布日期： [2018 年3 月 12 日 06:37 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/13 "2018-03-12T06:37:20Z")

</div>

> [@charles.zhou](#):
>
> 这个是debug错误记录

这个日志不对，你再找找。

---

<div class="post-metadata">

### 作者： ![charles.zhou](https://forum.magentochina.org/letter_avatar_proxy/v4/letter/c/3da27b/32.png) [@charles.zhou](https://forum.magentochina.org/u/charles.zhou)
#### 发布日期： [2018 年3 月 12 日 07:17 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/14 "2018-03-12T07:17:24Z")

</div>

![image](https://forum.magentochina.org/uploads/default/original/1X/d655a11d948fa58aca4778b64c52b7fd7bfeb615.png)  
没找到相关的错误日志，😅  
刚刚突然发现，我把浏览器宽度减小，就能显示内容出来，但是变形了。截图是浏览器显示的报错信息。你看下有没有用  
~~

---

<div class="post-metadata">

### 作者： ![Shuai](https://forum.magentochina.org/user_avatar/forum.magentochina.org/shuai/32/3_2.png) [@Shuai](https://forum.magentochina.org/u/Shuai)
#### 发布日期： [2018 年3 月 12 日 09:48 UTC](https://forum.magentochina.org/t/magento2%E5%88%87%E6%8D%A2%E4%BA%A7%E5%93%81%E6%A8%A1%E5%BC%8F%E6%8A%A5%E9%94%99command-returned-non-zero-exit-code/129/15 "2018-03-12T09:48:34Z")

</div>

前端这样，估计还是前端静态文件创建时出了问题，找下模板开发商吧。  
每个模板不同，个人确实没有办法一一解决
