文档 下载安装 商店 博客 问答 主机

magento2.0.x中PHP版本问题

magento2

#1

请问下,magento 2.0.x系统环境需求中PHP要求5.6.x, 7.0.2 or 7.0.6 ,
我现在手上有一个7.0.25, 兼容吗


#2

如果你使用的是 Magento 2.0.17那么根据官方的composer文件表明是 支持php 7.0.X全家

“php”: “~5.5.0|~5.6.0|~7.0.0”,

波浪号运算符~7.0.0,等同于我们常见的 >=7.0.0,所以说是支持的


#4

:grin:谢谢你的回答


#5

由于开源软件每天都在更新,一些细节问题,最好还是关注官方。
而且你用7.0.x系列,个人还是建议直接上Magento 2.1.X或者2.2.X
但是以上版本号标注里没有指明是否可以使用7.0.25,所以建议自行测试一下。