文档 下载安装 问答 主机

安装指定版本Composer

目前直接apt安装composer直接是2.x以上的最新版本。
而Magento2的依赖为1.x。所以需要手动安装composer

  1. 下载composer step
    php -r “copy(‘https://getcomposer.org/installer’, ‘composer-setup.php’);”

  2. 安装指定版本composer到/usr/bin/
    php composer-setup.php --install-dir=/usr/bin/ --filename=composer --version=1.10.19

使用该方法可以解决运行composer安装magento2时的报错:

Your requirements could not be resolved to an installable set of packages.

Problem 1
– Root composer.json requires magento/composer-root-update-plugin ~1.0 -> satisfiable by magento/composer-root-update-plugin[1.0.0].
– magento/composer-root-update-plugin 1.0.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
Problem 2
– Root composer.json requires dealerdirect/phpcodesniffer-composer-installer ^0.5.0 -> satisfiable by dealerdirect/phpcodesniffer-composer-installer[v0.5.0].
– dealerdirect/phpcodesniffer-composer-installer v0.5.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
Problem 3
– laminas/laminas-dependency-plugin[1.0.0, …, 1.0.4] require composer-plugin-api ^1.1 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
– magento/product-community-edition 2.4.1 requires laminas/laminas-dependency-plugin ^1.0 -> satisfiable by laminas/laminas-dependency-plugin[1.0.0, …, 1.0.4].
– Root composer.json requires magento/product-community-edition 2.4.1 -> satisfiable by magento/product-community-edition[2.4.1].

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.